Mise à jour chirurgicale

De Asso Val Libre
Révision de 17 janvier 2021 à 17:02 par Admin (discussion | contributions) (Votre version actuelle)

(diff) ← Version précédente | Voir la version actuelle (diff) | Version suivante → (diff)
Aller à : navigation, rechercher
 ATTENTION  / NIVEAU EXPERT / INSTRUCTIONS POTENTIELLEMENT DANGEREUSES
Comment mettre à jour de manière sélective vers une distribution plus récente ?
Rappel : ... < bionic (18.04) < c < disco (19.04) < e < focal (20.04) < groovy < h ...
Ci-après, les sources bionic, focal et groovy sont actives (cf sources.list).

Votre version actuelle

  • Votre version actuelle (installée) :
lsb_release -d
Description:	Ubuntu 20.10
Attention 
la version affichée est «virtuelle» (mais normalement correcte), c'est la version liée à celle du paquet base-files ! Si on installe une version antérieure de ce seul paquet, le résultat est modifié ;-)
apt install base-files/focal
lsb_release -d
Description: Ubuntu 20.10

Une version plus «techniquement» correcte, est celle d'un paquet fondamental au fonctionnement du système, par exemple la librairie libc6, fondamentale pour l'exécution d'une grande partie des applications.

 apt-show-versions libc6
 libc6:amd64/groovy 2.32-0ubuntu3 uptodate

Version préférée

Il est possible de spécifier la distribution que l'on souhaité privilégier lors des installations de paquets. Dans /etc/apt/apt.conf :

 APT::Default-Release "focal";
NB : La version choisie n'est pas nécessairement celle en cours/installée.
Mais c'est effectivement un choix qui permet d'éviter de trop facilement basculer vers des versions supérieures ;-)

Verrouillage de mise à niveau

Avec le réglage précédent, la mise à jour normale de paquet ne peut dépasser la version focal / 20.04.

Exemple : le paquet evince est disponible en trois versions (bionic/focal/groovy), la version focal est installée. Une mise à jour devrait donc proposer la version supérieure, groovy.

apt-cache policy evince
evince:
 Installé : 3.36.0-2
 Candidat : 3.36.0-2
Table de version :
    3.38.0-1 500
       500 http://fr.archive.ubuntu.com/ubuntu groovy/main amd64 Packages
*** 3.36.0-2 990
       990 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 Packages
       100 /var/lib/dpkg/status
    3.28.2-1 500
       500 http://fr.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
Or
 apt install evince
 ... evince est déjà la version la plus récente (3.36.0-2)...
La version groovy n'est pas proposée ! Il faut la demander explicitement
 apt install evince/groovy
Cette commande n'est cependant pas suffisante car elle n'autorise l'utilisation de grovvy que pour le seul paquet evince. Or evince possède des dépendances dans groovy qui ne seront donc pas autorisées. Pour débloquer l'ensemble il faut demander
 apt install evince -t groovy   Attention, dangereux